Çözüldü Yardım Facebookta konuyu paylaşınca konunun içerisindeki resim çıkmıyor

apocalypse

Yönetici
Yönetim Ekibi
Katılım
9 Haz 2014
Mesajlar
1,070
Reaction score
1,003
Puanları
113
Web sitesi
xenforo.web.tr
PHP Versiyonu
PHP v7.0.x
XenForo Versiyonu
XF 1.5.x
Evet böyle bir problemin çıkması normaldir,xenforo resimli ve resimsiz her konu için facebook opengraph logosunu yayınlıyor.Şöyle bir değişiklikle bunu kaldırıp yerine sayfadan resim seçebilirsiniz.
Şablonlar-> open_graph_meta açın ve bu kodları bulup kaldırın.
Kod:
<xen:if is="{$avatar}"><meta property="og:image" content="{$avatar}" /></xen:if>
<meta property="og:image" content="{xen:helper fullurl, @ogLogoPath, 1}" />
 
Yapılan değişiklikleri test etmek için
https://developers.facebook.com/tools/debug/
https://developers.facebook.com/tools/debug/og/object/ <-- fetch ile

adreslerini kullanabilirsiniz.
 

MySimS3k®

Emektar Üye
Katılım
30 Nis 2016
Mesajlar
357
Reaction score
333
Puanları
63
Yaş
39
Konum
Adana
Web sitesi
xenforotr.com
PHP Versiyonu
PHP v7.1.x
XenForo Versiyonu
XF 1.5.x
Kullanmış olduğunuz temanın open_graph_meta şablonunda aşağıdaki kodu bulun ve silin
Kod:
 <xen:if is="{$avatar}"><meta property="og:image" content="{$avatar}" /></xen:if>
    <meta property="og:image" content="{xen:helper fullurl, @ogLogoPath, 1}" />
Yine kullanmış olduğunuz temanın thread_view şablonunu açın ve aşağıdaki kodu bulun ve silin

Kod:
<xen:comment><xen:set var="$avatar">{xen:helper avatar, $thread, m, 0, 1}</xen:set></xen:comment>
 
Son düzenleme:

FuatCelik

Kayıtlı Üye
Katılım
18 Tem 2016
Mesajlar
4
Reaction score
1
Puanları
3
Yaş
33
Web sitesi
minecrackturkiye.com
Kullanmış olduğunuz temanın open_graph_meta şablonunda aşağıdaki kodu bulun ve şilin
Kod:
 <xen:if is="{$avatar}"><meta property="og:image" content="{$avatar}" /></xen:if>
    <meta property="og:image" content="{xen:helper fullurl, @ogLogoPath, 1}" />
Yine kullanmış olduğunuz temanın thread_view şablonunu açın ve aşağıdaki kodu bulun ve silin

Kod:
<xen:comment><xen:set var="$avatar">{xen:helper avatar, $thread, m, 0, 1}</xen:set></xen:comment>
yaptım ve halen aynı durumda
 

MySimS3k®

Emektar Üye
Katılım
30 Nis 2016
Mesajlar
357
Reaction score
333
Puanları
63
Yaş
39
Konum
Adana
Web sitesi
xenforotr.com
PHP Versiyonu
PHP v7.1.x
XenForo Versiyonu
XF 1.5.x
Varsayılan temanın düzenleme yaptığınız tema olduğundan emin misiniz? Yaptığımız testlerde biz bir sorun yaşamadık
 

OsmanT

Kayıtlı Üye
Katılım
29 Eyl 2016
Mesajlar
402
Reaction score
176
Puanları
43
Yaş
33
Konum
Konya
Web sitesi
www.pazarr.com
PHP Versiyonu
PHP v7.1.x
XenForo Versiyonu
XF 1.5.x
Bu işlemleri yaptıktan sona 1veya 2 hafta içinde düzeliyor facenin belleğinden silinmesi 15 20 günü buluyor
 

BozkurT

Yönetici
Yönetim Ekibi
Katılım
15 Haz 2014
Mesajlar
98
Reaction score
111
Puanları
33
Yaş
39
Konum
istanbul
Web sitesi
www.definemekani.com
PHP Versiyonu
PHP v7.0.x
XenForo Versiyonu
XF 1.5.x
aslında pek birşey yapmaya gerek yok, bende aynı sorunu yaşadım, sadece ftp deki klasorden orjınal logo ile kendi yaptıgım loguyu değiştim, 1 hafta ıcerısınde guncelleme oldu.
ftp deki orjınal logonun uzerıne kendı logonu yazdır, (orjınalı logoyu yedek al) admin paneldende yazdırdıgın ftp yolunun doğru oldugundan emın ol, gerisi facebook a bırak.
admin panel<görünüm<stil özellikleri<Header and Navigation<Facebook Open Graph Logosu - buranın sağındaki kutuya ftp deki logonun yolunu yaz. ////logo.og.png.
kolay gelsın.
 

kappadox

Kayıtlı Üye
Katılım
25 Ara 2016
Mesajlar
52
Reaction score
8
Puanları
8
Yaş
37
Web sitesi
www.antiksirlar.com
PHP Versiyonu
PHP v5.4.x
XenForo Versiyonu
XF 1.5.x
Mevcut sorun bende de var benim istediğimde facede link paylaşıldığında sayfa içindeki resimlerden biri çıksın. Daha öncesinde oluyordu. fakat nezaman 1.5.10 u yükledim olmaz oldu. Ne yaparsam yapayım sayfa içi resimleri çıkartamıyorum. Tam 1 ay oldu.
 

apocalypse

Yönetici
Yönetim Ekibi
Katılım
9 Haz 2014
Mesajlar
1,070
Reaction score
1,003
Puanları
113
Web sitesi
xenforo.web.tr
PHP Versiyonu
PHP v7.0.x
XenForo Versiyonu
XF 1.5.x
Facebook konu linkinden resim çekerken metadaki resmi alıyor,meta da yoksa sayfa içindeki diğer grafik dosyalarınından birini alır.Eğer bu logo çıkıyorsa metadaki logo silinmemiştir.
 

kappadox

Kayıtlı Üye
Katılım
25 Ara 2016
Mesajlar
52
Reaction score
8
Puanları
8
Yaş
37
Web sitesi
www.antiksirlar.com
PHP Versiyonu
PHP v5.4.x
XenForo Versiyonu
XF 1.5.x
Tamamdır hocam hallettim. Mevcut şablonunu seçmemişim biraz daha dikkat edince halletim.
 

deli56

Kayıtlı Üye
Katılım
19 Tem 2017
Mesajlar
20
Reaction score
4
Puanları
3
Yaş
38
Web sitesi
yerliforum.com
XenForo Versiyonu
XF 1.5.x
Kullanmış olduğunuz temanın open_graph_meta şablonunda aşağıdaki kodu bulun ve şilin
Kod:
 <xen:if is="{$avatar}"><meta property="og:image" content="{$avatar}" /></xen:if>
    <meta property="og:image" content="{xen:helper fullurl, @ogLogoPath, 1}" />
Yine kullanmış olduğunuz temanın thread_view şablonunu açın ve aşağıdaki kodu bulun ve silin

Kod:
<xen:comment><xen:set var="$avatar">{xen:helper avatar, $thread, m, 0, 1}</xen:set></xen:comment>
Diger kodlari buup sildim ama thread_view şablonunun icinde gosterdiginiz kod yok. Diger yollari denemem ragmen facebookta paylasim xapandan xenforo logosu cikiyor.
 

Emre

it's over
Kayıtlı Üye
Katılım
2 Ağu 2014
Mesajlar
735
Reaction score
272
Puanları
63
Yaş
32
Konum
Alanya
Web sitesi
xfdestek.com
PHP Versiyonu
PHP v5.6.x
XenForo Versiyonu
XF 1.5.x
thread_view kodlarını ekte verir misin
 

DieseL

BıçKıN Admin
Yönetici
Yönetim Ekibi
Katılım
9 Şub 2016
Mesajlar
650
Reaction score
731
Puanları
93
Konum
Tekirdağ
Web sitesi
www.xenforo.web.tr
PHP Versiyonu
PHP v7.1.x
XenForo Versiyonu
XF 1.5.x
Diger kodlari buup sildim ama thread_view şablonunun icinde gosterdiginiz kod yok. Diger yollari denemem ragmen facebookta paylasim xapandan xenforo logosu cikiyor.
bu kodu aratın
Kod:
<xen:set var="$avatar">{xen:helper avatar, $thread, m, 0, 1}</xen:set>
 

kappadox

Kayıtlı Üye
Katılım
25 Ara 2016
Mesajlar
52
Reaction score
8
Puanları
8
Yaş
37
Web sitesi
www.antiksirlar.com
PHP Versiyonu
PHP v5.4.x
XenForo Versiyonu
XF 1.5.x
Konuyu hortlatmak gibi olacak ama xenfor 2.0.X versiyonlarda bu sorunu nasıl hallederiz.
 
Üst